Usage Engine Cloud Edition [US Region] - Service Interruption

Incident Report for DigitalRoute

Resolved

This incident has been resolved. Stream execution services in the US region are fully operational and stable. Thank you for your patience.
Posted Jun 10, 2026 - 04:44 UTC

Update

We have partially recovered the service, and streams are now running.
Posted Jun 10, 2026 - 04:03 UTC

Update

We have partially recovered the service, and streams are now running.
Posted Jun 10, 2026 - 03:58 UTC

Monitoring

We are closely monitoring the situation and will provide further updates as needed. We appreciate your patience and understanding as we work to resolve this issue.
Posted Jun 10, 2026 - 02:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 01:43 UTC

Identified

We have identified the cause of the service interruption.

Stream execution service functionality is being affected by the unavailability of third-party database services.

Current status:
• Impact: Users may experience problems with the stream executions.

We are closely monitoring the situation and will provide further updates as needed. We appreciate your patience and understanding as we work to resolve this issue.
Posted Jun 10, 2026 - 01:41 UTC
This incident affected: Usage Cloud Stream Execution (US).